【はじめに】

ダウンロードして頂きまして誠に有難うございました。
是非、インストールして試用されて下さい。

ネットパトロール　Ｖｅｒ　１．2．０

Ver
日付
改修内容
1.2.0
2002.07.08
  1. (追加)ホストに対してのルート確認機能を追加。
1.1.0

2002.06.18
  1. (追加)カレンダー機能の追加と年間カレンダーによる非稼動スケジュール設定の追加。
  2. (追加)監視対象に対してＰｉｎｇ確認の有無を変更可能にした。
  3. (修正)ツリービュー(左側のビュー)をドラッグした状態でプログラム異常を起こす問題を修正。
  4. (修正)リストビュー(右側のビュー)をドラッグした状態でプログラム異常を起こす問題を修正。
  5. (修正)グループ追加を一旦表示後、コンピュータの下位にあるノードを右クリックするとグループ追加が再表示される問題を修正。
1.0.0
2002.05.01
 初リリース


【概要】

ＴＣＰ／ＩＰをサポートするコンピュータを監視する管理用ツールです。
（Windows2000/NT/95/98/Me,Unix,Linux,ルータなど）
機能については、【特徴】を参照して下さい。
試用期間を初回起動日から７日にしています。試用期間中の機能制限は
一切ありませんので是非、試されて下さい。


概要

【特徴】

（１） ネットワーク上でＴＣＰ／ＩＰを実装したコンピュータが正常稼動しているか監視する事が可能です。
（２） ネットワーク上のコンピュータでＴＣＰ／ＩＰサービスが稼動しているか監視する事が可能です。
★ポート番号を指定してサービスを監視する。
★拡張監視機能。
   ☆SQL Serverに対してSQLを投入し結果が正しく取れる事を監視する。
   ☆WWWサーバ（ＨＴＴＰ／ＨＴＴＰＳ）上のHTMLが正常にリターンする事を監視する。
   ☆ＦＴＰサービスにログオンできるか監視する。
☆ポート番号を指定してサービスを監視する拡張ポート監視。

各使用者がＶＢ６のプログラム（ＤＬＬ）を作成し、ネットパトロールの拡張監視機能に組込む事が可能です。ＤＬＬをテストする為のプログラムとＤＬＬのサンプルソースを付属しています。

（３） 障害発見時に管理者へ通知する事が可能です。

★ネットパトロールが稼動するコンピュータ上のディスプレイにパトロールランプ（回転します）を最大表示して警告します。
★ネットパトロールが稼動するコンピュータにサウンドカードが装備されている場合、サイレンを鳴らして警告します。（音量調整の可能）
★Ｅメールにメッセージを送信し警告します（同一管理者に２メールアドレスまで設定可能）
★Ｗｉｎｄｏｗｓポップアップサービス（Ｗｉｎｐｏｐｕｐ．ｅｘｅ）にメッセージを送信し警告します。
★フリーソフト（メッセージ君）にメッセージを送信し警告します。（メッセージ君はネットパトロールから警告メッセージを検知した場合、ディスプレイにパトロールランプを最大表示して警告をします）（Ｖｅｃｔｏｒサイトに登録済みhttp://www.vector.co.jp/vpack/browse/person/an020027.html）
（４） 障害を検出した場合に、ログ情報の書出しを行い参照できます。ログ情報の保管日数を指定する事で保管期限が過ぎた情報は自動的に削除されます。
（５） チェック対象のコンピュータをグループ（「人事システム関連」など）で管理する事が可能です。また、システム管理者をグループ単位またはコンピュータ毎に割当てる事も可能です。
（システム管理者をグループに割当てた場合、グループ内のコンピュータに異常を検知した時点で警告を促します）
（６） チェック対象のコンピュータが定期リブートなどを行う場合、チェックをさせないスケジュール管理（日付・曜日・時間指定）が可能です。


【動作環境】

本ソフトウェアは以下の環境で動作します。
ＯＳ | Ｗｉｎｄｏｗｓ 2000 Server | ○
 | Ｗｉｎｄｏｗｓ 2000 Professional | ○
 | Ｗｉｎｄｏｗｓ NT 4.0 Server | ○
 | Ｗｉｎｄｏｗｓ NT 4.0 Workstation | 未検証
 | Ｗｉｎｄｏｗｓ Ｍｅ | 未検証
 | Ｗｉｎｄｏｗｓ 98 | ○
 | Ｗｉｎｄｏｗｓ 95 | ○
メモリ | 32MB以上
インストールに必要な ディスク容量 | １０MＢバイト
必要な機器 | （必須）：マウス、キーボード、ディスプレイ、ＬＡＮカード
 | （任意）：サウンドカード、スピーカ 異常を検知した場合、サイレンを鳴らします。コンピュータにサウンド機能がない場合は、音はなりません。
必要なプロトコル | ＴＣＰ／ＩＰプロトコル
監視対象ホスト | Ｗｉｎｄｏｗｓサーバ・クライアント、ＵＮＩＸサーバ、ルータなど
異常事態の連絡 | Ｅメールで連絡する場合は、ＳＭＴＰサービスが稼動しているサーバが必要です。 （Ｅメール機能を未使用の場合はSMTPサーバは不要です）
 | Ｗｉｎｄｏｗｓポップアップサービスで連絡する場合は、クライアント側でwinpopup.exeを起動しておく必要があります。
 | メッセージ君（フリーソフト）で連絡する場合は、クライアント側でメッセージ君を起動しておく必要があります。 http://www.vector.co.jp/vpack/browse/person/an020027.html


【インストール】

以下の手順に従い、インストールを行って下さい。

ファイルの構成 アーカイブを解凍するとC:\TEMP\NetPatrolに以下のファイルが生成されます
SETUP.EXE | セットアッププログラム
SETUP.LST | セットアップリスト
NetPatrol.CAB | セットアップされるファイル群
sample.LZH | 拡張機能作成用のサンプル
NetPatrol.chm | ＨＥＬＰファイル（このファイル）
インストーラ
（１） | 使用許諾書を確認します。
（２） | 解凍されたSETUP.EXEを起動します。 （この例はWindows2000Proで実行しています）
（３） | セットアップ画面が表示され『ＯＫボタン』をクリックして下さい。
（４） | セットアップされる保存先に問題がなければ、『インストールボタン』をクリックして下さい。 保存先を別の場所に変更する場合は、『ディレクトリ変更ボタン』をクリックしセットアップ先のディレクトリを指定後、『インストールボタン』をクリックして下さい。
（５） | Windows95/98の場合は、既存グループ内のｽﾀｰﾄｱｯﾌﾟ（半角カナ）を選択後、『継続ボタン』 をクリックして下さい。 Windows2000Pro/Srvの場合は、既存グループ内のスタートアップ（全角カナ）を選択後、『継続ボタン』をクリックして下さい。
（６） | インストールが実行されます。
（７） | インストールが完了しました。『ＯＫボタン』をクリックして下さい。
（８） | コンピュータを再起動して下さい。 再起動後にスタートアップに保存されたショートカットが起動され、タスクバー横のアイコンに [image] が表示されます。
インストール
ファイル 		インストール先のフォルダーに格納されるファイルを下記します。
NetPatrol.exe | ネットパトロール実行プログラムファイル
NetPatPort.dll | 拡張機能用（ポートチェック）ＤＬＬファイル
NetPatftp.dll | 拡張機能用（ＦＴＰチェック）ＤＬＬファイル
NetPatDB.dll | 拡張機能用（ＳＱＬ Ｓｅｒｖｅｒチェック）ＤＬＬファイル
NetPatwww.dll | 拡張機能用（ＨＴＴＰ・ＨＴＴＰＳチェック）ＤＬＬファイル
NetPatrol.MDB | コンピュータ情報を格納するデータベースファイル
Siren.wav | サイレン用のサウンドファイル
その他にもシステムファイルがＷｉｎｄｏｗｓシステムフォルダーにインストールされます。
その他の必要なファイル Ｖｅｃｔｏｒより「Visual Basic 6.0 SP5 ランタイムライブラリ」をインストールして下さい。

以上でインストールは完了です。


概要

【メニュー・バー】

イメージ
解説 ネットパトロールのメニュー・バーには、以下のメニューが含まれています。
ファイル | 当ソフトを閉じる事が可能です。
表示 | 再表示やアクティブ画面の設定が可能です。
実行 | 定期チェックの有無を設定可能です。
ツール | ソフトの環境設定やログ情報が参照可能です。
ヘルプ | ライセンス登録およびバージョン情報が参照可能です。


【ファイル】

イメージ
解説 「ファイル」メニューには、以下のコマンドがあります。
閉じる ソフトウエアを閉じます。


【表示】

イメージ
解説 「表示」メニューには、以下のコマンドがあります。
再表示 | 登録されたコンピュータ情報を読み直しツリービューに再表示します。
最前面表示 | ネットパトロールの画面をＷｉｎｄｏｗｓ画面上もっとも前に表示させるか否か切替えます。


【実行】

イメージ
解説 「実行」メニューには、以下のコマンドがあります。
接続確認 定期的にコンピュータチェックを実施するか停止させるか切替えます。


【ツール】

イメージ
解説 「ツール」メニューには、以下のコマンドがあります。
オプション | ソフトウエア環境情報の設定画面を表示します。
カレンダー | カレンダー情報の設定画面を表示します。
Tracert確認 | ホストに対してのルート検索を行います。
ログ確認 | 監視中に障害が発生したログ情報の参照画面を表示します。


概要

【アクション】

イメージ
解説
常に前面表示 | On：本ソフトをＷｉｎｄｏｗｓ画面の最前面に常に表示させます。
異常時のお知らせ拡大表示 | On：通信チェック中に異常を検知した場合、本ソフトを最大表示させます。
起動時にチェック開始 | On：本ソフトを起動時に通信チェックを開始します。
非通信チェック対象を表示 | On：コンピュータ表示ビユーに通信チェック非対象のコンピュータを表示しません。

内容を変更した後は『更新ボタン』を押して下さい。


【環境】

イメージ
解説
ログ保存期間 | 障害を検出した場合に、ログ情報の書出しを行います。その場合のログ情報を保存する日数を指定して下さい。なお、保管期限が過ぎた情報は自動的に削除されます。（最大９９９日過去まで）
管理ＤＢファイル選択 | 本ソフトは使用者が登録された全ての情報を管理ＤＢで保管しています。初期値はインストール先のフォルダー内のNetPatrol.mdbが設定されいます。 通常は初期設定値のままご使用下さい。 活用例としては、監視サーバ自身が障害にあう恐れを想定し、２台以上の監視サーバ（本ソフトを導入している）を稼動させ、管理ＤＢは共に同じ物を使用したい時にご活用下さい。
パトロールランプ | On：本ソフトが異常を検知した場合、稼動コンピュータのディスプレイにパトロールランプ（回転します）を最大表示して警告します。 Off：異常を検出してもパトロールランプを表示しません。
パトロールランプのテストボタン | ディスプレイにパトロールランプ（回転します）を最大表示します。
サウンド使用 | On：本ソフトが異常を検知した場合、稼動コンピュータのサウンド機能を経由しwavファイルを鳴らして警告します。（稼動コンピュータにサウンドカードとスピーカが存在しない場合は音はなりません） Off：異常を検出してもサウンドを鳴らしません。
サウンドのテストボタン | サウンドファイル選択で指定したwavファイルを鳴らします。
サウンドファイル選択 | 本ソフトが異常を検知した場合、サウンドで警告する時のwavファイルを選択します。 初期設定値のwavファイルはピーポーピーポー音(Siren.wav)です。
障害時の音量 | 異常を検知しサウンドファイルを鳴らす時だけの音量を指定します。

内容を変更した後は『更新ボタン』を押して下さい。


【通信チェック】

イメージ
解説
チェック間隔（秒） | 監視する間隔を指定します。 例として、５台の監視対象コンピュータがありチェック間隔を90秒と指定されていた場合、５台全てをチェックした後、９０秒ウエイトし再び５台をチェックするサイクルで稼動します。
接続ＮＧ時の再チェック（回） | 異常を検知した場合、通常はメールを使用し管理者に通達しますが、チェック間隔を９０秒としていた場合でかつコンピュータ障害が継続していれば９０秒毎に管理者へ異常を知らせるメール文書が送られてしまいます。 そこで異常を検出後は再チェックの監視をスキップしメールの大量送信を防ぐ為に指定して下さい。
サービスチェック時 のタイムアウト（秒） | 標準のサービス監視機能としてポートチェック機能を装備していますが、そのタイムアウトのデフォルト値を指定します。

内容を変更した後は『更新ボタン』を押して下さい。


【緊急通知】

イメージ
解説
異常時に警告メッセージを送信する | On：コンピュータ管理者やグループ管理者に警告を送信します。 Off：警告のメッセージを送信しません。
ポート番号 | フリーソフト（メッセージ君）にメッセージを送信し警告します。メッセージ君が使用しているポート番号を設定します （メッセージ君はＶｅｃｔｏｒサイトに登録済みhttp://www.vector.co.jp/vpack/browse/person/an020027.html）
ユーザ名 | メッセージ君に登録されるユーザ名（ネットパトロールを管理している人の名前など）を指定します。
ＰＯＰサーバ | Ｅ－Ｍａｉｌで警告メッセージを送信する場合に使用するPOPメールサーバを指定します。(ＰＯＰが必要でない場合はＳＭＴＰサーバのアドレスと同じものを指定して下さい)
ＳＭＴＰサーバ | Ｅ－Ｍａｉｌで警告メッセージを送信する場合に使用するSMTPメールサーバを指定します。
アカウント名 | Ｅ－Ｍａｉｌを送信する場合のメールアカウントを指定します。

内容を変更した後は『更新ボタン』を押して下さい。


【カレンダー画面】

イメージ
解説 コンピュータ単位に非稼動スケジュールを登録する際にベースとして表示される企業カレンダーを登録します。
カレンダー名 | 本社カレンダーや支社カレンダーなどカレンダー名称を入力します。
西暦 | 西暦の年度を指定します。 （入力範囲：ＯＰ年－１年からＯＰ年＋２０年）
カレンダー | 平日、土曜、休日・祭日などにクリックし色分けします。


【Tracert確認画面】

イメージ
解説 指定されたホストに対してのルート検索を行います。
ルート検索が失敗した場合は１０回までリトライを行います。
Host名 or IP | ホスト名もしくはＩＰアドレスを入力します。
IPアドレス | ホスト名より検索したＩＰアドレスが表示されます。
Host名の解決 | ルート検索を行う際に個々のホスト名を検索します。 Ｏｎ ：検索する Ｏｆｆ：検索しない
データ長 | ルート検索を行う際に発行するデータ長を指定します。


概要

【ログ確認画面】

イメージ
解説 監視中に検知した際の警告メッセージの内容が参照できます。尚、障害が発生していない日は
ログは存在しない為、表示されません。
日付 | 異常を検知した稼動日を表示します。
時間 | 異常を検知した時刻を表示します。
グループ | 異常を検知したグループ名を表示します。
ＩＰアドレス | 異常を検知したコンピュータのＴＣＰ／ＩＰアドレスを表示します。
名称 | 異常を検知したコンピュータの名称を表示します。
内容 | 異常を検知した際の警告内容を表示します。


【ヘルプ】

イメージ
解説 「ヘルプ」メニューには、以下のコマンドがあります。
ライセンス登録 | ソフトウエアのライセンスキー設定画面を表示します。
バージョン情報 | バージョン情報を表示します。


概要

【ライセンス登録画面】

イメージ
解説 ソフトウエアのライセンスを登録します。正しく登録された場合、試用期間が外れ継続してご使用になれます。
ユーザ名 | ユーザ名を入力して下さい。
ライセンスキー | ライセンスキーを入力して下さい。

全てを入力後に『登録ボタン』を押して下さい。


概要

【バージョン情報画面】

イメージ |
解説 | アプリケーション名、著作権、ライセンス、アプリケーションの説明を表示します。 ライセンスキーが未設定の場合は、試用期間が表示されます。


【監視情報】

イメージ
解説
左側のビュー説明
『ツリービューの構成』
  • グループ情報
    • コンピュータ情報
      • ポートチェック
      • 拡張機能監視情報
      • 非監視スケジュール
      • コンピュータ管理者
    • グループ管理者
指示 ポップアップ画面
空白部分を右クリック
グループ追加 監視グループを新規に作成します。
グループ情報を右クリック
定期診断をしない | 選択したグループのみ定期チェックを実施しません。
コンピュータ追加 | 選択されたコンピュータをグループ情報に登録します。
グループ変更 | 選択されたグループ情報を更新します。
グループ削除 | 選択されたグループ情報を削除します。
コンピュータ情報を右クリック
定期診断をしない | 選択したコンピュータのみ定期チェックを実施しません。
今すぐ診断 | 定期的なチェックを待たず即座に選択したコンピュータをチェックします。
ポートチェック追加 | 選択したコンピュータに監視対象のポートチェックを登録します。
拡張機能追加 | 選択したコンピュータに監視対象のチェック（Ｗｅｂ・ＦＴＰ・ＤＢＭＳ等）を登録します。
非監視スケジュール追加 | 選択したコンピュータに非監視時間帯の情報を登録します。
非監視カレンダー追加 | 選択したコンピュータに非監視時間帯の情報を登録します。
コンピュータ変更 | 選択されたコンピュータ情報を更新します。
コンピュータ削除 | 選択されたコンピュータ情報を削除します。
ポートチェック情報を右クリック
ポートチェック変更 | 選択されたポートチェック情報を削除します。
ポートチェック削除 | 選択されたポートチェック情報を削除します。
拡張機能情報を右クリック
拡張機能情報変更 | 選択された拡張機能情報を削除します。
拡張機能情報削除 | 選択された拡張機能情報を削除します。
非監視スケジュール情報を右クリック
非監視スケジュール情報変更 | 選択された非監視スケジュール情報を削除します。
非監視スケジュール情報削除 | 選択された非監視スケジュール情報を削除します。
非監視カレンダー情報を右クリック
非監視カレンダー情報変更 | 選択された非監視スケジュール情報を削除します。
非監視カレンダー情報削除 | 選択された非監視スケジュール情報を削除します。
コンピュータ管理者／グループ管理者を右クリック
担当者削除 選択された担当者を削除します。
右側のビュー説明
監視状況を表示します。
左の画面内の『チェック状況』ボタンを押すと
全状況＜＝＞異常状況のみの表示画面と切替える事が可能です。
但し、１００件までしか表示しません。100件を超えた場合、古い情報から削除されます。

尚、表示されたチェック状況データを左ダブルクリックすると次の選択された情報のみのメッセージを表示します。
左側のビューでコンピュータ情報のノードをマウスで選択した場合、登録されたコンピュータの情報が表示されます。

また、その選択されたコンピュータの通信状況も表示されます。
指示 ポップアップ画面
空白部分を右クリック
追加 管理者を新規に登録する場合に選択。
担当者を右クリック
追加 | 管理者を新規に登録する場合に選択。
変更 | 管理者の情報を変更する場合に選択。
削除 | 管理者の情報を削除する場合に選択。


【グループ画面】

イメージ
解説 監視対象コンピュータをグループで管理します。

グループＣＤ | グループのコードを入力します。
グループ名 | グループの名称を入力します。
説明 | 簡単な説明を入力します。
診断有無 | Ｏｎ：定期チェックの対象（監視対象）にします。 Ｏｆｆ：定期チェックの対象外にします。 （グループ配下の全コンピュータは監視されません）

全てを入力後に『登録／更新ボタン』を押して下さい。


【コンピュータ画面】

イメージ
解説 監視対象のコンピュータを管理します。

グループ名 | グループの名称が表示されます。
ＩＰアドレス | コンピュータのＩＰアドレスを入力します。 形式: ［255］.［255］.［255］.［[255］
種類 | コンピュータの種類を選択します。または直接入力して下さい。
コンピュータ名 | コンピュータの名称を入力します。
表示名 | メイン画面に表示されるコンピュータ名を入力します。
説明 | 簡単な説明を入力します。
診断有無 | Ｏｎ：定期チェックの対象（監視対象）にします。 Ｏｆｆ：定期チェックの対象外にします。
Ping有無 | Ｏｎ：コンピュータの稼動確認でＰｉｎｇチェックを実施します。 Ｏｆｆ：Ｐｉｎｇチェックの対象外にします。 ※インターネット環境のサーバ等を監視する場合、セキュリティポリシーにより、Ｐｉｎｇを返さない設定がされている場合があります。その場合はＯｆｆに設定し、ポート監視もしくは拡張監視機能で監視されるようにして下さい。
異常音再生 | Ｏｎ：異常を検知した場合、サウンド設定された音を鳴らします。 Ｏｆｆ：異常を検知しても音は鳴らしません。
異常判断回数 | 定期チェックを連続して『異常判断回数』だけ連続した場合に障害が発生していると認識します。
タイムアウト | Ｐｉｎｇのタイムアウト値を入力します。1000以上の値を指定します。 ネットワークの回線速度やコンピュータの処理能力が原因で、タイムアウトの時間前に返事が返ってこない場合は異常と判断しますので、この場合はタイムアウト値を調整して下さい。
カレンダー名 | カレンダー画面で登録した情報を指定します。（必須ではありません）

全てを入力後に『登録／更新ボタン』を押して下さい。


【ポートチェック画面】

イメージ
解説 任意のＴＣＰポート番号を指定しサービスを監視する事ができます。
監視内容としては指定されたポートをチェックし２回連続で接続失敗した場合、サービス停止中と判断します。
コンピュータ名 | コンピュータの名称を表示します。
ポート番号 | 監視対象のサービスが使用しているポート番号を入力して下さい。
表示名 | 監視対象のサービス名（理解しやすい名称でＯＫ）を入力して下さい。
参考 | 一般的なサービスがどのポートを使用しているか参照できます。 （注）この情報は全て正しいとは限りませんので最終確認はお使いのソフトを調査して下さい。

全てを入力後に『登録／更新ボタン』を押して下さい。


【拡張機能画面】

イメージ
解説 拡張された監視機能を選択し監視する事ができます。
尚、各使用者がＶＢ６のプログラム（ＤＬＬ）を作成し、ネットパトロールの拡張監視機能に組込む事が可能です。ＤＬＬをテストする為のプログラムとＤＬＬのサンプルソースを付属しています。

コンピュータ名 コンピュータ名を表示します。
拡張機能の選択 拡張機能として用意されている監視タイプを選択します。
機能名 | 監視の機能名称を表示します。
ファイル名 | ＤＬＬファイルの名称を表示します。
バージョン | ＤＬＬファイル内のバージョン番号を表示します。

目的にあった監視タイプを選択後に『選択ボタン』を押して下さい。


【ＦＴＰ情報画面】

イメージ
解説 ＦＴＰサーバの稼動チェック（実際にログインできる事を確認する）を行います。
アドレス | 監視対象コンピュータのＩＰアドレスが表示されます。
ログインＩＤ | 指定されたＦＴＰサーバにログイン可能なログインＩＤを入力して下さい。
パスワード | ログインＩＤのパスワードを入力して下さい。
Ａｎｏｎｙｍｏｕｓ | 匿名ログインする場合にチェックします。
タイムアウト | ＦＴＰチェックの返事を待つ秒数を入力します。
リトライ時の待機時間 | 前回のＦＴＰチェックで接続できなかった場合、連続してＦＴＰチェックをリトライしますが、前回から今回までのリトライ待機時間を入力します。
接続失敗判断回数 | ＦＴＰチェックで接続できなかった場合、リトライを実施します。その時、何回連続した場合障害とみなすかを入力します。
全てを入力後に『確認ボタン』を押し正しく稼動チェックする事を確認後、『登録／更新ボタン』を押して下さい。


WWW情報画面

【ＷＷＷ情報画面】

イメージ
解説 Ｗｅｂサーバの稼動チェック（実際にＵＲＬリクエストして返事が返ってくる事を確認する）を行います。
種別 | Ｗｅｂ通信のアクセス種類を選択します。
ＵＲＬ | 監視対象コンピュータのＩＰアドレスが表示されます。ドメイン指定でも可能です。
ユーザＩＤ | ログオンを必要とするＷｅｂ画面に対してユーザＩＤを入力します。 （補足：デーモンが稼動しているかのチェックしか実施していませんので指定無しでも問題ないと思います。）
パスワード | ログインＩＤのパスワードを入力して下さい。 （補足：デーモンが稼動しているかのチェックしか実施していませんので指定無しでも問題ないと思います。）
制限時間 | ＷＷＷチェックの返事を待つ秒数を入力します。
リトライ時の待機時間 | 前回のＷＷＷチェックで接続できなかった場合、連続してＷＷＷチェックをリトライしますが、前回から今回までのリトライ待機時間を入力します。
接続失敗判断回数 | ＷＷＷチェックで接続できなかった場合、リトライを実施します。その時、何回連続した場合障害とみなすかを入力します。
全てを入力後に『確認ボタン』を押し正しく稼動チェックする事を確認後、『登録／更新ボタン』を押して下さい。


【Ｐｏｒｔ情報画面】

イメージ
解説 Ｐｏｒｔチェックの標準版と異なりリトライ回数の設定やリトライするまでの待ち時間を設定可能にし、稼動チェック自身の正確性を向上しています。
アドレス | 監視対象コンピュータのＩＰアドレスが表示されます。
ポート番号 | 監視対象のサービスが使用しているポート番号を入力します。
タイムアウト | ポートチェックの返事を待つ秒数を入力します。
サービス名 | 監視対象のサービス名（理解しやすい名称でＯＫ）を入力して下さい。
リトライ時の待機時間 | 前回のポートチェックで接続できなかった場合、連続してポートチェックをリトライしますが、前回から今回までのリトライ待機時間を入力します。
接続失敗判断回数 | ポートチェックで接続できなかった場合、リトライを実施します。その時、何回連続した場合障害とみなすかを入力します。

全てを入力後に『確認ボタン』を押し正しく稼動チェックする事を確認後、『登録／更新ボタン』を押して下さい。


【ＳＱＬ　Ｓｅｒｖｅｒ情報画面】

イメージ
解説 ＭＳ社製のＳＱＬ　Ｓｅｒｖｅｒの稼動チェック（実際にクエリーを実行し確認する）を行います。
アドレス | 監視対象コンピュータのＩＰアドレスが表示されます。
ＤＢ名 | ＳＱＬ Ｓｅｒｖｅｒ上に存在するデータベース名を入力して下さい。
ログインＩＤ | 指定されたデータベースを参照可能なログインＩＤを入力して下さい。
パスワード | ログインＩＤのパスワードを入力して下さい。
ＳＱＬ文 | 参照可能なクエリー文を入力して下さい。
タイムアウト | 確立しようとした接続を終了して、エラーを発生させるまでの待機時間を指定します。
全てを入力後に『確認ボタン』を押し正しく稼動チェックする事を確認後、『登録／更新ボタン』を押して下さい。


非監視スケジュール

【非監視スケジュール画面】

イメージ
解説 定期的なコンピュータのシャットダウンなどを異常と検知しないように、非チェックのスケジュールを登録します。（複数スケジュールを登録可能）
コンピュータ名 | コンピュータの名称を表示します。
非監視時刻 | チェックを実施しない時間帯を入力します。 00時00分～23時59分までの時間帯が入力可能。
稼動 | チェックを実施しない曜日を選択して下さい。

全てを入力後に『登録／更新ボタン』を押して下さい。


【非監視カレンダー画面】

イメージ

解説 定期的なコンピュータのシャットダウンなどを異常と検知しないように、非チェックのスケジュールを登録します。（複数スケジュールを登録可能）
コンピュータ名 | コンピュータの名称を表示します。
カレンダー名 | コンピュータ画面で設定されたカレンダー名が表示されます。
西暦 | 西暦の年度を指定します。 （入力範囲：ＯＰ年－１年からＯＰ年＋２０年）
カレンダー | 非稼動スケジュールが設定されている日付は緑色のマークが表示されます。 ・スケジュールを登録する場合は日付を左クリックすると時刻設定の非監視スケジュール画面が表示されます。 ・登録された情報を参照する場合は日付を右クリックして下さい。
非監視時刻 | カレンダーの日付を右クリックした場合に非稼動スケジュールが設定されていれば、チェックを実施しない時間帯が表示されます。


【担当者管理画面】

イメージ
解説 コンピュータやシステムを管理している担当者を登録します。

職番 | 担当者を認識できる固有の番号（社員番号など）を入力します。
氏名 | 担当者の氏名を入力します。
所属名 | 担当者の所属名を入力します。
電話 | 担当者の緊急連絡先の電話番号を入力します。
ＩＰアドレス | 担当者の常時使用しているＰＣのＩＰアドレスを入力します。 担当者が警報種別で説明している『ポップアップサービス』及び『メッセージ君』を使用しないのであればＩＰアドレスは入力する必要はありません。
警報種別 | 担当者がネットパトロールで連絡を受けるクライアントソフトを選択します。 ポップアップサービスを選択した場合は、担当者側のクライアントでwinpopup.exeを起動しておく必要があります。 メッセージ君（フリーソフト）を選択した場合は、担当者側のクライアントＰＣでメッセージ君を起動しておく必要があります。http://www.vector.co.jp/vpack/browse/person/an020027.html
Ｅ－Ｍａｉｌ連絡 | Ｏｎ：担当者はＥ－Ｍａｉｌで警告メッセージを受取る。 Ｏｆｆ：担当者はＥ－Ｍａｉｌで警告メッセージを受取らない。
連絡先１ | Ｅ－Ｍａｉｌのアドレスを入力します。（社内のＥ－Ｍａｉｌなど）
連絡先２ | Ｅ－Ｍａｉｌのアドレスを入力します。（携帯のＥ－Ｍａｉｌなど）

入力後に『登録／更新ボタン』を押して下さい。


【Tracert確認画面】

イメージ
解説 コンピュータに対してルート検索を行います。
コンピュータ名 | コンピュータの名称を表示します。
IPアドレス | コンピュータのＩＰアドレスが表示されます。
Host名の解決 | ルート検索を行う際に個々のホスト名を検索します。 Ｏｎ ：検索する Ｏｆｆ：検索しない
データ長 | ルート検索を行う際に発行するデータ長を指定します。


【拡張機能作成（サンプル）】

構成図

補足 ・当サンプルのソースコードは本製品（NetPatrol.LZH）を解凍されたフォルダー直下にsample.lzhとして保存されています。解凍ツール等をご使用になりお使い下さい。

・サンプルのソースに変更不可能な行が識別できるようにコメントを入れています。お間違えのないようにお願い致します。
（例）
    Private Sub Class_Initialize()
      '*** 変更不可 *********************************************************
      m_Proc = "I"　　　　　　　　　　　 '*** (変更×)

      '*** 初期化 ***********************************************************
      m_URL = "" 　　　　　　　　　　　　'*** (変更○)
      m_RequestTimeout = 5 　　　　　　　'*** (変更○)
      m_Password = ""　　　　　　　　　　'*** (変更○)
      m_UserName = "anonymous"　　　　　 '*** (変更○)
      m_WaitTime = 3 　　　　　　　　　　'*** (変更○)
      m_Retry = 2　　　　　　　　　　　　'*** (変更○)
      With FrmCommon.Inet　　　　　　　　'*** (変更○)
          .AccessType = icUseDefault　　 '*** (変更○)
          .Protocol = icFTP　　　　　　　'*** (変更○)
      End With　　　　　　　　　　　　　 '*** (変更○)
    End Sub
注意事項

１．当ソフトはＶＢ６で作成していますので、ＶＢ６以外での開発は保証できません。

２．必須メソッドやプロパティなどを削除されると正常に稼動しませんのでご注意下さい。

３．拡張機能用のＤＬＬファイルのファイル名を必ずＮｅｔＰａｔｘｘｘｘ.ＤＬＬとして下さい。xxxxの部分は任意の名称でＯＫです。

４．拡張機能ＤＬＬの中でクラス定義ファイルが存在しますが、そのクラスオブジェクト名(ClsNetPatrol)を変更しないようにお願いします。変更した場合は正常に稼動しません。

５．作成したＤＬＬは親ＰＧＭ（Netpatrol.exeまたはDllTest.exe）と同じフォルダーにセットアップして下さい。（ＤＬＬファイルをコピーして保存しただけでは正常に稼動しませんのでＶＢでＤＬＬ作成時の保存先をEXEと同じフォルダーに指定すれば検証できます）

６．サンプル（NetPatFTP）のソースコードの著作権は角田誠一にあり、放棄したわけではありませんが、ご購入されましたお客様で当ソースを改変し製品化させた物については角田誠一の著作権とは無関係なものとなります。また、お客様で製品化もしくはフリーソフトとして作成されました製品に関するソフトの不具合や質問についても当方とは無関係となりますので、一切の受付は致しません。

７．当ライセンスを1個ご購入されている状態で、監視用コンピュータ（Netpatrol.exe本体を稼動している）が存在し、かつ拡張監視Ｄｌｌの作成を行うために開発用コンピュータにNetpatrol.exeを導入する事はライセンス違反となりますので、ライセンスを別途ご購入されて下さい。ただし、開発用コンピュータにDLLTest.exeを導入され稼動確認する場合は改めてライセンスを購入する必要はありません。


【使用許諾書】

使用者は、以下の条項に承諾した場合のみ、本ソフトウェアを使用することができます。
(本ソフトウェアを実行した場合には、以下の条項に承諾したものとみなします。)

（１） | 本ソフトウェアを使用して発生した､いかなる金銭的､時間的損失、あるいはいかなる損失に対しても作者、ソフトウェアの配布者、あるいはいかなる人物も、責任を一切負いません。
（２） | 仮に本ツールあるいはドキュメントに不具合、障害、記入漏れあるいはその他の不備などが存在する場合でも、(作者が可能と判断した範囲で改修の努力は行いますが)作者は修正する義務はありません。
（３） | ハードウェア故障、本製品以外のソフトウェアの不具合(例えばオペレーティングシステムの不具合)、ネットワークのトラブルあるいは細いネットワークが原因とする本ソフトウェアの動作異常はサポートの対象外とさせていただきます。
（４） | ユーザ登録(送金)する前に、必ず試使用し正常動作を確認してください。
（５） | ネットワーク サーバーとして使用されている記憶装置にソフトウェアのコピーを 1 部保存することが許可されており、この記憶装置に内部ネットワークを通じて接続されているコンピュータに、ソフトウェアをインストールすることができます。また、ネットワーク アプリケーション サーバーとして使用されている記憶装置にソフトウェアをインストールし、その記憶装置に内部ネットワークを通じて接続されているコンピュータからそのソフトウェアを実行することもできます。ただし、この記憶装置からソフトウェアをインストールする各コンピュータおよび記憶装置からソフトウェアを実行する各コンピュータについて、個別にライセンスを取得し割り当てる必要があります。ライセンスを特定のコンピュータに割り当てると、そのコンピュータに独占的なライセンスが無期限に割り当てられたことになります。ソフトウェアを実行するための 1 つのライセンスは、複数のコンピュータ間での共有または同時使用できません。
（６） | 基本的にコンピュータ１台に１ライセンスとカウントしますが、１台のコンピュータをマルチブート（複数ＯＳの切替え）されている場合は複数ＯＳ分インストールしてもＯＫです。
（７） | 本製品の仕様、あるいはドキュメントは予告なく変更される可能性があります。
（８） | 本ソフトウェアの改造、リバースエンジニアリング等を禁止します。また同等の行為により、送金せずにパスワードによるロックを解除することを禁止します。

本製品、あるいはドキュメントに含まれる社名、製品名等は、その版権所有者の商標または登録商標です。


著作権

【著作権に関して】

（１） | 本ソフトウェアは(NetPatrol.lzhの形式である限り)自由に配布、コピーをしてもかまいません。ただしライセンスのコピー、配布はできません。また、いかなる場合でも、著作権は作者（角田 誠一）に属し、放棄しません。
（２） | 転載に関しましては、アーカイブに一切手を加えないという条件で許可いたします。 その場合は、著作者に問い合わせする必要はありません。
（３） | ＰＣ雑誌やその他メディアにて紹介・収録したい場合は事前に電子メールにてお問い合わせください。


送金ユーザ登録

【送金】

本製品はシェアウェアとなっています。試用期間が超えて継続してご使用される場合は、
作者に送金して頂くようにお願いします。

条件 送金は必ず以下の2点を満たした方のみ行ってください。送金された場合には、作者は送金したユーザが以下の２点を満たしたものとして扱います。

（１）試用期間中に、本ソフトウェアが正常に動作していた。
（２）送金者は、使用許諾書に同意した。
ライセンスの定義 | ライセンスは、本ソフトウェアをインストールするコンピュータにつき１ライセンスとさせて頂きます。
価格 | ３，０００円でお願いします。
送金方法 以下の二通りがあります。都合の良い方法で送金願います。
シェアレジ
(VECTOR) 		シェアレジ(VECTOR)での送金は、VECTORのホームページからお願い致します。
銀行振込をする方法 銀行振込にて送金された方は、入金が確認された後、ライセンスキーを送付させて頂きますので、作者へ下記の内容をメールで送信して下さい。

振込先の口座１ （イーバンクに口座をお持ちの方はご利用下さい） | 銀行：イーバンク銀行 支店番号：２０９ 口座番号：１１０９３５５ 名義：角田 誠一 (ツノダ ｾｲｲﾁ)
振込先の口座２ | 銀行：東京三菱銀行 支店：北九州支店 口座の種類：普通預金 口座番号：０４２２００２ 名義：角田 誠一 (ツノダ ｾｲｲﾁ)
メール送付 | 送信先 | tsunodaseiichi@yahoo.co.jp
 | メールタイトル | NｅｔPatrolの登録依頼
 | メール内容 | ソフトウェア名とバージョンＮｏ ソフトウエアの本数 振込年月日 振込された名前（フリガナ） 振込金額 振込した口座番号 ライセンスキー送付先のメールアドレス

振り込みを確認次第、ライセンスキーを送付致します。
振り込みから１週間たっても、何も連絡がない場合には、再度メールの送信をお願い致します。

尚、お客様のお名前、メールアドレス等、プライベートな情報は一切公表致しませんのでご安心下さい。

ライセンスキーを入手後は、ライセンス登録画面で登録して下さい。


【ライセンス登録】

ライセンスキーを入力するには以下の手順に従います。

（１） | ツールバーより[ヘルプ]＝＞［ライセンス登録］を選択します。
（２） | 送付されたライセンスキーとユーザ名を入力します。
（３） | [登録]をクリックします。

以上で登録は終了です。