はじめに

Diary for Suiteをご利用いただきまことにありがとう御座います。

構成

Diary for Suiteは以下の3つのアプリケーションで構成されています。

Diary

Diaryはパームデバイス上で日記をつけるためのアプリケーションです。Diaryはパームウェアです。

Diary for Desktop

Diary for DesktopはPC上で日記の管理や、HTMLへの出力をするためのアプリケーションです。

Diary Conduit

Diary Conduitはパームデバイス上のDiaryと、PC上のDiary for Desktop間のデータを同期するアプリケーションで、HotSyncマネージャに組み込まれ、HotSync時に呼び出されます。

バージョン

本バージョン(1.0J)のDiary Suiteを構成する3つのアプリケーションそれぞれのバージョンは以下の通りです。

Diary 1.0.1J
Diary for Desktop 1.0.0J
Diary Conduit 1.0.0J

Diary Suiteの履歴

1.0

  • 初公開

アンインストールについて

本アプリケーションをお使いのPCからアンインストールする場合は、コントロールパネルのアプリケーションの追加と削除より、「Diary Suite 1.0J」をアンインストールして下さい。「Diary Palm Conduit」は自動的にアンインストールされるので、手動でのアンインストールは行わないで下さい。またパームデバイス上のアプリケーション「Diary」は、Windowsのアンインストーラを使用してもアンインストールされません。お手数ですが、パーム上で削除下さい。

ご連絡先

バグ報告、お問い合わせ、ご意見、ご感想等は以下アドレスまでお寄せください。

kazuhiro@robios.org

また、このアプリケーションに関する新情報やサポートは以下サイト（作者ホームページ）にてご確認ください。

http://hp.vector.co.jp/authors/VA029885/

免責事項

このソフトウエアの使用により発生したいかなる損害に対しても、作者は一切の責任を負いかねます。ご利用者の責任の元、ご利用してください。

著作権

このアプリケーションの著作権は作者、酒井 和広 (kazuhiro@robios.org)、に帰属します。 転載・コピーは自由ですが、転載の際には作者宛にあらかじめご連絡ください。また、再配布はこのままのパッケージで再配布下さい。

Diary Help Version 1.0.0J
Last Updated: 2002/5/15


ライセンスについて

Diary Suite 1.0J (Diary/Diary Conduit/Diary for Desktop)はシェアウェアです。30日間の試用期間を超えてご利用になる場合は、規定のライセンス料金をお支払いの上、ライセンスキーを入手ください。

ライセンス料金のお支払い

Diary Suite 1.0J 1 ライセンス 1,000円

Diary Suite 1.0Jのライセンス料金は、1ライセンスにつき\1,000です。お支払いは銀行振込とVectorのシェアレジよりお選び頂けます。銀行振込はライセンスキーの発行まで1日から2日かかります。Vectorのシェアレジによるお支払いでは、ライセンスキーを即時発行することができます。

銀行振込によるお支払い

下記口座へお振込み後、お手数ですが作者までご送金日時、お名前、ご連絡先（Email等）をメールにてお知らせ下さい。

鹿児島銀行姶良支店 （かごしまぎんこうあいらしてん）
普通 947373
名義 酒井 和広 （さかい かずひろ）

作者メールアドレス: kazuhiro@robios.org

Vectorシェアレジによるお支払い

Vectorシェアレジにてお支払いください。下記ボタンをクリックするとお支払い画面が開きます。

1,000円 Diary Suite 1J

ライセンスキーの入手と登録

ライセンス料金をお支払い頂きますと、ライセンスキーを発行致します。ライセンスキーは次の手順で登録します。

1. HotSyncの動作設定を開く
タスクバーのHotSyncアイコンを右クリックし、動作設定を選びます。（右図）
2. Diary Conduitの動作設定を開く
コンジットリストよりDiaryを選び、右側の「変更」ボタンをクリックします。（下図）
3. ライセンスキーの登録
ライセンスキーを登録します。画面下部の「シェアウェアキー」の入力フォームへキーを入力し、右側の「OK」ボタンをクリックします。（下図）これで登録が完了しました。


はじめに

Diaryは、Palmハンドヘルド上で日記をつけるためのアプリケーションです。

特徴

  • その日の天気、起床時間、就寝時間、起床・就寝時の気分、朝食、昼食、夕食等も記録することができます
  • シンプルな画面
  • デスクトップアプリケーションのDiary for Desktopとデータを提携します

履歴

1.0.1

  • Theme Pro 2.0との組み合わせでFatal Errorがでてしまうバグを修正
  • プライベート時にスクロールバーを操作すると本文が見れてしまうバグを修正

1.0a (1.0.0a)

  • 初公開

動作環境

現在、以下のデバイスにて動作を確認しております。

  • Palm m100
  • Palm IIIc
  • Palm Vx
  • Palm m505
  • Visor Edge
  • Sony Clie N700

上記以外のデバイスでの動作報告が頂ければ幸いです。

ご連絡先

バグ報告、お問い合わせ、ご意見、ご感想等は以下アドレスまでお寄せください。

kazuhiro@robios.org

また、このアプリケーションに関する新情報やサポートは以下サイト（作者ホームページ）にてご確認ください。

http://hp.vector.co.jp/authors/VA029885/

免責事項

このソフトウエアの使用により発生したいかなる損害に対しても、作者は一切の責任を負いかねます。ご利用者の責任の元、ご利用してください。

著作権

このアプリケーションの著作権は作者、酒井 和広 (kazuhiro@robios.org)、に帰属します。 転載・コピーは自由ですが、転載の際には作者宛にあらかじめご連絡ください。また、再配布はこのままのパッケージで再配布下さい。


アプリケーションの起動

アプリケーションを起動します。起動しますと、右図のようなフォームが表示されます。タイトルバーには今日の日付が表示されます。タイトルバー右部の左右矢印では、日付を移動することができます。また、カレンダーボタンをクリックすると、カレンダーを開くことができ、そこから移動したい日付へジャンプすることも可能です。

次のステップ

  • 天気を選択


天気を選択

「天気を選択」の左側にある下矢印をクリックすると、天気リストが表示されます（右図）。ここから、今日の天気を選択します。

次のステップ

  • 日記を入力


日記を入力

日記の本文を入力します。

次のステップ

  • 詳細情報の入力


詳細情報の入力

その日の詳細情報を入力します。詳細ボタンをクリックすると、詳細フォームが表示されます。

次のステップ

  • 起床時間・就寝時間・気分の入力


起床時間・就寝時間・気分の入力

その日の起床時間と、起床時の気分を入力します。起床時間の入力は、「起床」の右側にある「12:00 am」の部分をクリックします。すると、起床時刻を入力するフォームが表示されるので、上下矢印を使い、起床時刻を入力します（右図）。また、起床時の気分の入力は、「気分」の左側にあるした矢印をクリックし、気分を選択します。

就寝時間と就寝時の気分は、お休みになる前か翌朝、入力下さい。

次のステップ

  • 献立の入力


献立の入力

朝食、昼食、夕食を入力します。それぞれの入力欄の右側にある下矢印をクリックすると、過去5件の入力が参照できます。入力欄に直接入力するか、リストの中より選ぶか、いずれかの方法で入力して下さい（右図）。

次のステップ

  • 日記の保護


日記の保護

プライベートのチェックボックスをチェックすることにより、日記をシステムのデータ保護設定にて保護することができます。データ保護設定が、「データを非表示」に設定されている場合、プライベート設定された日付の日記は表示されません（右図）。

＊データ保護設定が「データを非表示」になっている状態でプライベートをチェックし、詳細フォームで完了ボタンを押しメインフォームに戻っても、まだこの時点では日記は表示されます。一度他の日付へ移動するか、アプリケーションを終了すると、日記は表示されなくなります。これは、プライベートをチェックした後もその直後は日記を編集することができるようにするためです。

関連事項

  • アプリケーション設定


アプリケーション設定

メニューを開き、「オプション」内の「設定」を開くことにより、アプリケーションの設定をすることができます（右図）。

「新しい日記は常にプライベート」がチェックされると、以降新しく作成される日記は、デフォルトでプライベート設定がオンになります。プライベート設定をオフにしたい場合は、日記の詳細情報フォームのプライベートチェックボックスのチェックをはずします。

関連事項

  • 日記の保護


はじめに

Diary for Desktopは、パームウェアDiaryの日記データをPC上でバックアップ・編集・入力・HTML出力するためのアプリケーションです。

特徴

  • パームウェアのDiaryとデータを同期することができます
  • 日記をホームページ公開用にHTML出力することができます
  • スタイルシートを選択することにより、多彩なデザインの出力が出来ます
  • スタイルシートはXMLとXSLTの知識があれば自作することができます

履歴

1.0.0

  • 初公開

ご連絡先

バグ報告、お問い合わせ、ご意見、ご感想等は以下アドレスまでお寄せください。

kazuhiro@robios.org

また、このアプリケーションに関する新情報やサポートは以下サイト（作者ホームページ）にてご確認ください。

http://hp.vector.co.jp/authors/VA029885/

免責事項

このソフトウエアの使用により発生したいかなる損害に対しても、作者は一切の責任を負いかねます。ご利用者の責任の元、ご利用してください。

著作権

このアプリケーションの著作権は作者、酒井 和広 (kazuhiro@robios.org)、に帰属します。 転載・コピーは自由ですが、転載の際には作者宛にあらかじめご連絡ください。また、再配布はこのままのパッケージで再配布下さい。


メイン画面

各部分をクリックすると詳しい説明へジャンプできます。

日記本文 カレンダー パームユーザー 天気 起床・就寝時間 起床時・就寝時気分 プライベート 朝食・昼食・夕食 日記の削除 HTMLへ出力 バージョン画面の表示

カレンダー

編集中の日付を選択することができます。カレンダー上部の左右矢印をクリックすることで年月を選択し、その後日付をクリックすると、指定の日へ移動できます。また、カレンダー下部の「今日」をクリックすると、今日の日付へ即座にジャンプできます。

ユーザー選択

パームユーザーの選択をします。

天気

天気を選択します。右側の下矢印をクリックし、リストの中より天気を選択します。

日記

日記本文を入力します。

起床時間・就寝時間

起床時間・就寝時間を入力します。ボックス中の「時」または「分」の部分をクリックし、右側の上下矢印で設定します。

起床時・就寝時気分

起床時と就寝時の気分を入力します。右側の下矢印をクリックし、リストの中より気分を選択します。

プライベート

編集中の日記をプライベート設定することができます。

注) ここでのプライベート設定はパームデバイス上でのプライベート設定への反映を意味します。Diary for Desktop上では、たとえプライベート設定をした状態でもデータは表示されます。

朝食・昼食・夕食

朝食・昼食・夕食を入力します。

日記の削除

現在編集中の日付の日記を削除する場合はここをクリックします。実際の削除の前に、確認の画面がでますので、本当に削除しても良い場合のみ、「OK」ボタンをクリックして下さい。

HTMLへ出力

日記をHTMLへ出力します。詳しくは別ページの「日記をHTML出力する」をご覧下さい。

バージョン画面の表示

バージョン情報の画面を表示します。


日記をHTML出力する

DiaryやDiary for Desktopで入力した日記データをホームページ公開用にHTML形式で出力します。

まずはメイン画面上のツールバーより、「HTML作成」ボタンをクリックします。(右図)
HTML作成画面でHTML出力のオプション設定をします(下図）。下図をクリックし、それぞれの設定の詳しい説明にジャンプできます。
日記を作成する範囲、適用するスタイルシート、ソート順、またプライベートデータを含めるか否かを設定し、「作成」ボタンをクリックします。保存ウィンドウが開くので、HTMLファイルの保存先を選択し、保存してください。

作成範囲 スタイルシート ソート プライベートデータも含める HTML作成オプションの説明

作成範囲

HTML出力する日記の範囲を設定します。指定した月、指定した年、指定した範囲を選択した場合はそれぞれの右部の指定部も設定してください。

スタイルシート

出力する日記に適用するスタイルシートを選択します。スタイルシートは必要に応じて作成・調整ができます。詳しくは、「スタイルシートの作成」をご覧下さい。

ソート

出力する日記の並び順を設定します。昇順に設定すると古い日記から順に出力し、降順に設定すると新しい日記から順に出力します。

プライベートデータも含める

このオプションを設定すると、プライベート設定している日記もHTML出力されます。


スタイルシートの作成

ここからは、XMLとXSLTについての知識がある方が読まれることを想定してご説明致します。

Diary for Desktopは、XSLTの技術を使い日記のデータをHTMLへ変換します。Diary for Desktopは日記データを内部ではXML形式にて処理しています。HTMLの作成時は、与えられた範囲の日付の日記データを内部にてXML出力し、MSXML 3.0にて指定のスタイルシートを適用し、HTML出力しています。

スタイルシートを作成された方で公開しても構わない方は作者へご連絡ください。ホームページにてユーザー向けへ公開させて頂きたいと思います。

日記データのフォーマット

内部処理される日記データのフォーマットは以下の様になります。

<?xml version="1.0" encoding="Shift_JIS"?>
<Book>
  <Diary year="2002" month="5" day="10" weather="0">
    <Body>日記本文</Body>
    <Detail waketime="00:00" wakemood="0" bedtime="00:00" bedmood="0" breakfast="朝食" lunch="昼食" dinner="夕食"/>
  </Diary>
  <Diary year="2002" month="5" day="11" weather="1">
    <Body>次の日の本文</Body>
    <Detail waketime="00:00" wakemood="0" bedtime="00:00" bedmood="0" breakfast="朝食" lunch="昼食" dinner="夕食"/>
  </Diary>
</Book>

ルートタグは「Book」です。それぞれの日記データは「Book」タグの子の「Diary」タグに記述されます。日記本文は「Diary」の子の「Body」タグに記述されます。日記の詳細データは「Diary」の子の「Detail」タグのアトリビュートに記述されます。

「Diary」タグ

「Diary」タグは、「year」、「month」、「day」、「weather」アトリビュートを持ちます。

アトリビュートの説明
year | 「年」を表す実数値です。
month | 「月」を表す実数値です。(1～12)
day | 「日」を表す実数値です。(1～31)
weather 天気を表す実数値です。
天気値
0 | 未設定 | 1 | 晴れ
2 | 曇 | 3 | 雨
4 | 雷雨 | 5 | 雪

「Body」タグ

「Body」タグ内には日記本文が記述されます。「Body」タグにはアトリビュートはありません。

「Detail」タグ

「Detail」タグは、「waketime」、「wakemood」、「bedtime」、「bedmood」、「breakfast」、「lunch」、「dinner」アトリビュートをもちます。

アトリビュートの説明
waketime | 起床時間を表す文字列です。
wakemood 起床時の気分を表す実数値です。
気分値
0 | 未設定 | 1 | 良い
2 | 普通 | 3 | 悪い
bedtime | 就寝時間を表す文字列です。
bedmood | 就寝時の気分を表す実数値です。(wakemood参考)
breakfast | 朝食を表す文字列です。
lunch | 昼食を表す文字列です。
dinner | 夕食を表す文字列です。

スタイルシートの作成

下のXSLはスタイルシートのテンプレートです。

<?xml version="1.0" encoding="Shift_JIS"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
  <xsl:output method="xml" encoding="Shift_JIS"/>
  <xsl:template match="Book">
    <html>
      <head>
        <title>タイトル</title>
        <meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS"/>
      </head>
      <body>
        <xsl:apply-templates/>
      </body>
    </html>
  </xsl:template>
</xsl:stylesheet>

注) 「xsl:output」タグは必ず記述して下さい。また、「method」アトリビュートは必ず「xml」に指定してください。これはMSXML3.0にて正しくHTML出力をするために必要です。指定どおり出力はxhtmlになります。今後の開発ではMSXML以外のプロセッサを使用するなどしてplain text等の出力もできるようにしたいと思います。

Tips

日付の表示

<xsl:template match="Diary">の中で以下のように記述

<xsl:value-of select="@year"/>年<xsl:value-of select="@month"/>月<xsl:value-of select="@day"/>日

天気の表示

<xsl:template match="Diary">の中で以下のように記述

天気:
<xsl:choose>
<xsl:when test="@weather=1">晴れ</xsl:when>
<xsl:when test="@weather=2">曇り</xsl:when>
<xsl:when test="@weather=3">雨</xsl:when>
<xsl:when test="@weather=4">雷雨</xsl:when>
<xsl:when test="@weather=5">雪</xsl:when>
<xsl:otherwise>未記入</xsl:otherwise>
</xsl:choose>

朝食の表示

<xsl:template match="Detail">の中で以下のように記述

朝食: <xsl:value-of select="@breakfast"/>


はじめに

Diary Conduitは、パームデバイス上のDiaryと、PC上のDiary for Desktop間のデータを同期するアプリケーションです。HotSyncマネージャに組み込まれ、HotSync時に呼び出され動作します。単独では使用しません。

特徴

  • 本体へコピー、PCへコピー、同期、何もしないをサポートします
  • 日記データのパームデバイス上での保存期間を設定できます

履歴

1.0.0

  • 初公開

ご連絡先

バグ報告、お問い合わせ、ご意見、ご感想等は以下アドレスまでお寄せください。

kazuhiro@robios.org

また、このアプリケーションに関する新情報やサポートは以下サイト（作者ホームページ）にてご確認ください。

http://hp.vector.co.jp/authors/VA029885/

免責事項

このソフトウエアの使用により発生したいかなる損害に対しても、作者は一切の責任を負いかねます。ご利用者の責任の元、ご利用してください。

著作権

このアプリケーションの著作権は作者、酒井 和広 (kazuhiro@robios.org)、に帰属します。 転載・コピーは自由ですが、転載の際には作者宛にあらかじめご連絡ください。また、再配布はこのままのパッケージで再配布下さい。


HotSync動作の設定

DiaryのHotSync動作設定を行います。まず、以下の手順で設定ウィンドウを開きます。

1. HotSyncの動作設定を開く
タスクバーのHotSyncアイコンを右クリックし、動作設定を選びます。（右図）
2. Diary Conduitの動作設定を開く
コンジットリストよりDiaryを選び、右側の「変更」ボタンをクリックします。（下図）

動作設定画面

下の図をクリックして詳しい説明へジャンプできます。

HotSync機能の動作 本体上の日記の保存期間 両方のデータが更新された場合の優先順位 シェアウェアキー 標準として保存

HotSync機能の動作

HotSync時の動作の設定をします。

動作 | 説明
ファイルを同期

パームデバイスとデスクトップ上の日記データを同期します。両方のデータに変更があった場合は、優先順位で指定した優先データで上書きします。

注) Diary Conduitは複数のデスクトップでのHotSyncはサポートしていません。その場合、たとえ同期に設定しても何も行われません。複数のデスクトップで使用する場合は、1台のデスクトップで同期を行い、他のデスクトップでは何もしないに設定して下さい。
デスクトップが本体を上書き | デスクトップ上の保存期間内の日記データをパームデバイスへコピーします。パームデバイス上の日記データはコピー前に全削除されます。
本体がデスクトップを上書き | パームデバイス上の保存期間内の日記データをデスクトップへコピーします。デスクトップ上の保存期間内のデータはコピー前に全削除されます。
何もしない | 何もしません。データはいずれのデバイスへもコピーされません。

本体上の日記の保存期間

パームデバイスに保存する日記データの期間を設定します。たとえば3ヶ月間に設定すると、本体には今月、先月、先々月の日記データが蓄積され、それ以前のデータは削除されます。デスクトップにコピーしたデータはもちろん削除されません。

注) ここで設定した保存期間を超えてHotSyncを行わなかった場合、HotSync時に未だデスクトップにコピーされていないデータが削除されてしまう可能性があります。よって、HotSyncはまめに行ってください。

両方のデータが更新された場合の優先順位

HotSync動作を「同期」に設定しており、同期時にある日付のデータが、パームデバイスでもデスクトップでも変更されている場合、どちらのデータを優先するかを設定します。「本体のデータを優先」に設定すると、双方のデータに変更がある場合パームデバイス上のデータがデスクトップにコピーされます。「デスクトップのデータを優先する」に設定すると、双方のデータに変更がある場合デスクトップ上のデータがパームデバイスにコピーされます。

シェアウェアキー

シェアウェア登録をし、入手したライセンスキーをこちらへ入力して下さい。詳しくはこちらをご覧下さい。

標準として保存

「HotSync機能の動作」で設定した動作は1回限りの設定です。標準として登録する場合はこちらをチェックしてください。